ThemeLab's Blog

Stay up to date with our newest WordPress themes, WordPress plugins, WordPress tutorials, and other announcements.

WordPress 2.6 + bbPress = No Good

Last Updated on by

Some of you who frequent Theme Lab’s support forums may have noticed you aren’t able to login anymore.

Why is this? WordPress 2.6 – that’s why.

The cookie changes between 2.5.1 and 2.6 are so “radical” they render the WordPress-bbPress integration useless.

When is the bbPress update coming? Apparently, not any time soon.

WordPress-bbPress users are encouraged to stick with WordPress 2.5.1 until a stable bbPress update is released, but don’t hold your breath.

If you’re using a Theme Lab theme and need support, feel free to post a comment on the release post on the blog, and I’ll try my best to get back to you.

  • http://www.arthack.org ArtHack

    Hei hei…… I did not affect the

  • http://www.pliggs.com Geoserv

    Thanks for the heads up, I have been holding out on upgrading my blog until I see what all is not going to work anymore.

  • http://indielab.org IndieLab

    Ouch, that sucks. I would expect a fix to come to light shortly though. The WP team and community won’t let this go on for too long;)

  • Leland

    @Geoserv: No problem, glad you found this post useful.

    @IndieLab: That’s what I was expecting as well, although the word on the bbPress forums is that it’s not coming for a while. :(

  • http://www.wpimagerotator.com Matt

    I feel your pain! I had a working WP and BBPress forum going until I “upgraded” to WP 2.6! I’m working on trying to find a work-around, if I find an acceptable solution I’ll email you and let you know…

    Great site!

    -Matt

  • Leland

    Thanks Matt. I’m thinking of trying to “downgrade” back to 2.5.1, although I’m afraid that might cause more problems than it’s worth – so holding off on it for now.

  • http://ev9lve.com kronicdreamer

    It did not affect my site :/ or by teh time i got it running, it has been fixed … :)

  • http://www.cssjockey.com CSSJockey

    I have published a walk-through that helps you deep integrate the latest stable versions of WordPress(2.7.1) and bbPress(0.9.0.4), so if your themes are compatible with latest version of WordPress then they should work with bbPress too.

    You can find the step-by-step guide at Deep Integrating WordPress 2.7.1 and bbPress 0.9.0.4

    I don’t recommend that you downgrade back to WordPress 2.5.1 to use your themes with bbPress. There have been a number of major security updates after WP 2.5.1.

  • Leland

    @CSSJockey: Just skimming through that, it looks like a great guide. Thanks for letting me know.